Better organization of the camera/layer actions list

It would make finding things so much easier if things were better organized and consistent across the app.I love the app but finding things can be frustrating and a time waster.

It would help if the camera and layers actions section was grouped by type and if the conditions and actions were in the same sequence. Honestly, things are so inconsistent that I usually scan for the icons. It’s difficult to remember different arrangements. There are probably more areas but I know you want only 1 issue per post.


I agree, several things could be sorted better.


Youch! that is definitely hard to scan.
Lemme dig and see if there is a complex reason on why is it like this so and I’ll see where the ticket has to be created.
Thank you for reporting this!


Some work has to be done with Subjects, Verbs and other beautiful language related notions.
A ticket has been created on the internal backlog to do so :

  • Alphabetical order has been discarded because it is not scalable in translated engines
  • A relevancy order will be explored
  • A desired “pairing” of similar actions (the fact that Show and Hide are displayed close to each other) was acknowledged

I agree 100% Tho its not just cameras its EVERYTHING like when u search up “variable” the first thing that comes up is object variables and not scene and tween variables

1 Like

I agree. I think they need to do some research. Maybe get a group of users and somehow let them create mock-ups. And then maybe choose the most common approach. They need something. Everyone has their own preferences but there has to be something that is more predictable, more consistent.

I should probably start a new thread although this isn’t specific about just the timers but an overall lack of organization.

I’m not sure if wait or time scale belong with timers. At minimum they should be above or below the other timer actions. I would say below bc how often do you adjust the time scale? Pause and unpause should be next together or maybe even combined. Paused is true/false. Either way, I would put start first then either pause or delete.