[Bug] Particle Emitter not working properly, capacity/tank value isn't refresh

A particle emitter marked for deletion after running out of particles is not being deleted after changing its capacity value to just 1 in the events. It just keeps emitting particles as if the capacity value wasn’t changed.

Before updating GD it was working perfectly, but after the update all my particle emitters seem to be immortal unless I directly delete the object (and that ruins the residual effect I worked on my main project).

You can test the problem here:


I can’t download the json right now, can you post a screenshot of the events relating to deletion and setting the capacity to 1?

I’ve downloaded the .JSON, and run it in preview in GDEvelop. It worked fine, and the particle emitter was removed after the particles were depleted. I confirmed this by running it in debug mode and checking the instances in the debugger. I’m running GDevelop 5.0.0-beta112

However, although the capacity changed, the original number of particles (1000) were still emitted. It’s as if the original settings are used, and the new one is ignored.

Exactly, and I need to set the capacity of my particle emitters to infinite and then change it to another value in the events. But the capacity stays infinite, so my fx don’t work anymore.

I can’t put the screen capture right now, but the events are just a “On scene start” condition and a “Change capacity value”.

This is not due to the latest updates.
The problem of this property and probably others are not working well since the migration from GD4 to GD5.
We need some kind of a v2 or a new tests and review phase on the particle object IMO.
If you can report it on Github, it helps to track the issues.

It was working properly with a previous version of GD5. I updated from the last GD5 version I used for las time, to the one released yesterday or a few days ago, and then the particles emitters started doing that. I wasn’t using GD4.

Which was the previous working version?
I’ll run tests and check, but there is no changes in particles features in latest betas since months.
It make no sense to me.

I wasn’t careful enough to look wich version it was, but I just downloaded the newest version and then I update.

My project had been done in GD5 from the start ([WIP] Forestful), I’m just returning after more than a year.

@Bouh @Silver-Streak @MrMen

Thanks for your help!

@Bouh @Silver-Streak @MrMen

This seems still to be a problem.
Capacity and Flow can be changed but the emitter won’t run out of particles using the new amounts and continue to emit according to initial numbers.

Someone at GDevelop work on this Particle object, bug fixes and simplification are in good progress :wink: