Button disappearing on hover and I don't know why

A button has suddenly started disappearing on hover and I have no idea why. The text is still visible and it is only happening when interactions are activated. I have no idea why. It used to be fine and I certainly have not added any event to make the button invisible when hovered. All other buttons are behaving fine. Does anyone have a guess as to what might be going on?

Does the button object have a valid image for the hovered state?

If I delete the file name for the hover event, it looks like this when I hover over a button.

Thanks for the reply! It does have a valid image filename, just the standard Blue Button_Hovered.png

If I had somehow messed with the hover event by mistake, where would I be able to find and correct that? The second picture you posted does look very similar to what I am getting.

You can check the resource screen but it might be easier to delete the name and repick it from your project folder.



I changed the name of a resource.

Thanks. I’m sure now the name is correct. Is there anything else that could be causing this?

When I experimentally deleted the name I got those little pink squares at the corners. The problem before (and still, not that I changed the name back) does not include pink squares. Just that the button dissapears.

Not that I’m aware of. You can try restarting the app. Save it first. It sounds like it’s a valid image. IDK.

[i would create a copy of the project first. Either by using the save as dialog or the explorer and copying the actual project folder]

As a last resort, You can delete the button object completely from the project. If you click “no” to the second prompt, it won’t delete any events. Then when you re-add the button make sure to use the same name.


I tried the saving method and that didn’t help. When I click delete, I don’t get the message you show, I just get this: “Are you sure you want to remove this object? This can’t be undone.”

It’s the 2nd prompt after clicking yes or confirm. I just updated to the last version. The UI is going to take some time to get used to.


The popups are normally overlapped, I moved the smaller one.

Well, I tried that and the problem is still happening. Also, before posting on the forum I removed the button and then re-added all the events manually, which also did not help. Any other ideas?

Thanks for your help so far!

I’m out of ideas. Anyone else have any ideas?

Since I can’t solve the problem, I think I’m just going to start a new project. This was my first project, and I can see now that I could have everything a lot more efficiently. With fewer lines of code, there will be fewer chances to accidently cause something like this. Thanks for the help!
Of course if anyone does know what’s going on I am all ears.

Sorry to hear that. Are you using the app or the online version. I’ve had troubles with the online version.

I guess it could’ve gotten corrupted. They’ve had some bugs lately too. Make sure you’re using the newest version.

I’m using the online version and it is set to auto-update, so I guess it is the most recent.

I’ve lost image files with the online version. I personally don’t trust it but then when I use the online version, I’m using my old android phone. So, there’s also that.