Can Admob ID work parallel, as I'm requesting test ads, and somebody in another place is requesting real ads, simultaneously?

Hello everyone :slight_smile:

Recently, I published my game to Google Play Store.
It has ads by Admob.
That game has option “enable test mode set to “no”” action in “at the beginning of the scene” condition.

Now, I’m developing update of that game…

Question is: Can I test the game with “enable test mode set to “yes””, on my Android device/emulator?
I mean, doesn’t it affect to my published game’s ads?
Can Admob app ID work parallel, as I’m requesting test ads, and somebody in another place is requesting real ads, simultaneously?

Thanks in advance :slight_smile:

People playing the released game have non-test ads shown.
You set test mode to yes only on your testing apk/device, so test ads are shown to you.
No problem with that.

1 Like

Thank You very much! :slight_smile:

I begun the developing with “Test Ads”…
But, “Test Ads” is not working on my developer side. I don’t know about player’s side yet.
Looks like, I can’t test my game with my own Admob ID and same package name of game.
Because, when I tested my game with other demo Admob ID, other package name, it is working.

So, I have to test ads as new game.

Why it doesn’t work with my own Admob ID and same package name of my game? :thinking:

Do you get an error message?

There is not any error message.
Just not showing ads, like my game has not any ads.

P.s. I tested it only with “developer mode turned on” action.

And now, I’m testing it as “another new game” with its new name, package name, Admob app ID, … .
I don’t know which one data (name, package name, app ID, …) exactly affecting it. I don’t want to test everything one by one to know which one is exactly affecting it. Because, I’m worrying that my Admob app ID can be blocked, as Admob can consider that I’m manipulating and breaking the rules.

You check with an exported game app on mobile, right? Ads only show there.

Yes, of course. :slight_smile: I know it.
If You read this topic from beginning, it was ok (test ads were showing properly).
But now (when I’m developing update of my game) it’s not working as described everything above.

I’m not sure what you’re doing wrong.
Maybe you broke something somewhere along the way while setting up the test ads. :thinking:
Have you tried using the test ids instead of the test mode?

(shown in the admob actions)

Tried it (interstitial, not banner).
But not working.

Thanks anyway :slight_smile:

I think some Admob actions were changed some versions ago, maybe you never updated your project to account for these changes.
Open all your Admob actions and make sure that the fields are properly filled.

If You mean about version of my GDevelop program, it will update automatically when update appears.
And I’m using it as usual in my project. So, I’m using last version of GDevelop.

And I checked every my actions/conditions. Everything is ok.

Before I said, test mode is working if I change my game’s data (name, package name, …). So, I mean actions/conditions are working.

Maybe, looks like Admob doesn’t allow the requesting test ads and real ads simultaneously.
My Admob account is set properly (even app-ads.txt and anything else).

Maybe, You will try to repeat my situation with your project? And You probably see my problem.
I mean, I think, it is happening not only with me.

Thanks :slight_smile:

I don’t use Admob. :man_shrugging:
If the same project works or doesn’t depending on its package name, I guess you’re right, but it’s surprising. :thinking:
You should try to configure your phone as a testing device in the admob settings (on the admob website), so that you can use the production build and still get the test ads (supposedly).

Ok. Thank You very much :slight_smile: