Cannot fire bullets after adding timer

Hello there, I’m following this Beginner Tank Shooter tutorial and when I add the timer and preview my game, I am not able to see any bullets firing from the turret.

Any help would be appreciated.

tank tutorial says Turret.Direction() you have Turret.Angle() maybe is the mistake


I changed it to Turret.Direction() but it is still not working.
The only time I am able to fire is when I remove timer condition and I don’t know why is that.

Hello Guys,
I have figured it out. I guess the tutorial needs to be updated a little bit.

In the tutorial it says, “The first parameter, “Object”, indicates the name of the object. Leave it blank.” when adding the timer condition.

Well instead of leaving it blank, I selected the Turret object from the list and it worked for me.

1 Like

The tutorial is incorrect. I believe it was wrongly edited by someone who confused scene timer and object timer. Will add a warning

1 Like

i am having a similar issue, but this time i used the simple space shooter as a template for my game.

i used a variable bossFireCount to count each time the bossFire command is triggered.

the bossFire command triggers as seen in the feedback text in my game, but the bullet is NOT created

can someone help?

thank you in advance

i tried using the same lines of code inside the simple space shooter example (see red box) and it worked, but i cannot seem to get it to work inside my own game

thank you again