Changing scene is buggy


I am trying to learn to use gdevelop and have made a series of scene (at the moment 3) and want to change the scene upon reaching a finish flag. (It’s a 2d platformer)

This is the line I use to change the level. If I set the “stop any other paused scenes?” to No, it can change successfully, otherwise, the player hitbox doesn’t become invisible and starts moving without the actual player sprite. Moreover, the screen is stuck in place, and the player hitbox doesn’t interact with coins/enemies.

Ok, I set the option to “No”. Now level 1 → level 2 progression works. My issue is that when I try to do level 2 → level 3 progression, it doesn’t work anymore.

Same issue with the player hitbox.

Please let me know if you need any extra information! Any advice is welcomed!

Can you put your project worth images in a zip file and upload it here in the forum?
There’s an “Upload attachment” button under the writing area.

Or you can upload it in a file hosting service and send me the link in a PM to check it out :slight_smile:

If you are not using global variables that could change the events behavior, then it seems like a bug :neutral_face:

I’ve uploaded to the forum the project, it is really basic as I want to learn stuff with the engine. Still uses the default art and everything.

Look please and the scene events for level 1 and 2, and let me know what you find out. It is a bit annoying that there isn’t more information about this on the net :frowning:
GdevelopGame.7z (105 KB)

Should have seen that in the images, sorry :blush: . You’re using a “=” symbol in the action to change to the third level. For some reason that invalidates all your scene code :open_mouth:

Just remove the = and everything will work, it’s a bug and 4ian is working on a better expression parser (the one that should detect such errors, warns you and invalidate that specific action only, not the whole scene), so no better time to report it, thanks! :smiley:

That was it! I can’t believe that the default “=” causes such issues as to break the whole scene. I hope this is reported and fixed.

Seems that it’s fixed :slight_smile:
Note that the “=” is not default, probably you were using the action to change the animation by number, were that symbol is the default second parameter, then you switched the action to use the animation by name and the second parameter was kept, but if you use the action without previous information the default value is “” (an empty string) :wink:
Anyway, it’s pretty easy to replicate and switching from the numeric animation to names is common, so again thanks for let us know! :smiley: