Closing the preview closes GDevelop

HI, so I was working on a game which I made in windows but, after that i changed to linux and had to move the game folder to the linux partition. But, the game started having many problems. I had check if the game works before coping it to linux. Link o the game:

  • The game started lagging alot even if there is nothing power hungry. My game is pretty light and I haven’t seen it lag

  • Closing the preview closes GDevelop. I tried closing the preview from the task bar thinking that I was accidently closing both. But, still closes

  • Some events don’t work. I had an event where it will center the camera on an object. But, it stopped working.

  • Some fonts break. I don’t know if the font was outside the game folder. but, I remember having all the fonts in the game folder. Not sure about this one.

Start by checking your resources in Game properties.
(your link doesn’t work)

1 Like

Thank you so much, Any idea why GD closes when I close the preview. A simple question on that, If the engine gets the assets through the path or the path of the game folder, then how does the game work when I share the game to multiple people through Github or something

Hi, I fixed the paths of all the objects as you said. There was a image called “.PNG”, which I thought was the problem to all of this and fixed the name thinking that I fixed it. But, It didn’t. After that, at first, the game’s FPS went to normal. But, then after that it was back to lagging again. And also, I found some more bugs:

  • I tried opening the developer toolbox to maybe find the issue. And that was… bugged too! The preview screen and the toolbox were like fighting for area and just getting resized every second. Here are some images:

  • The closing preview closes GDevelop thing is now random, Sometimes it works and sometimes it doesn’t

  • Some events straight up doesn’t work. I had the enemies spawn at random points in an object. But, it does not work. The script for it is there in it!! You can see a little text showing how many enemies are there in the last picture. I also had the orange enemies shoot the player, and it is not working and the events for it are there. Here are the images:

I have made a commit in “Test-branch” with the changes in the repo here:

Also if I commit the game folder that is still in windows to the repo and clone the repo to linux, will it fix it?

404 page on your link
I see nothing special on your screenshots.
Which build of GDevelop you use ?
There is action for resize the game resolution or window, or something like that?
Which OS?

1 Like

Please confirm also if the bugs you mention are specific to your project or if they happen with any project.

1 Like

I am pretty sure it is only happening in this project as I am working on others too at the moment and they don’t have any problem. But, just to be sure, I will be testing some others. Can you wait for tomorrow as I am not on my computer right now. Thanks

1 Like

I don’t know why you can’t access the repo. Is it some permission problem? Does this link work:
I have no clue why it is not working. The first 3 screenshot shows what happens when I open developer toolbox. It freaks out. The last 3 show that some events don’t work. Ah, I am using the linux Appimage build of beta 101, which I used Appimage launcher to integrate it to the desktop. It might be the problem. But, surely not as other projects do work without any problem. Ya, I have a center camera on object and some others (Not sure which events I used as I experimented with it).
I am using Linux mint 20. I will give more info about what events and proper OS version and others as I am not 100% sure. Thanks

not yet

1 Like

I have made the repo public, does it work now?
The newer commit is in the “Test-branch”. and the unchanged one is the master
EDIT: I have commited the newest change (Changed resizing problem that tries to fix the toolbox problem) in “Console-fix”

Hi, some more updates, - The new changes have been commited to the “Console-fix” branch in the repo !

Here are the info about my graphics , OS version, GDevelop version, etc…

OS - Linux Mint 20 Cinnamon
Cinnamon version - 4.6.7
Linux kernel version - 5.4.0-54-generic
Graphics - Intel Corporation 4 Series Chipset Integrated Graphics Controller

Gdevelop version - version

Just a quick question, If I fix the path problem in the game folder that is still in windows and commit it to the repo and clone that to linux, will it be fixed?

Hi, I made the repo private as I don’t want anyone to take my game a publish it before I do. So, I have made a drive to share it.
The Looped-master is the game without any changes.
Looped-Console fixes the resizing issue.
Looped-Test-branch has the correct path for the objects.
I think you can still access the repo from the link.

So it’s just a problem of events in the end?

1 Like

I don’t think the closing preview closing gdevelop is a event problem. And the console is still freaking out when I remove the condition (Which should not happen). And the events not working problem, it might be fixable if I just rebuild it. And by the way I forgot to say that the circle disappears when I “lose” the game. The game should not do anything with the loop at all, it should stay how it was. You can see it when you play the game.

  • I agree there should be something to prevent the console resize issue. Do you want to report it yourself on GDevelop’s github?
  • I could not reproduce the closing GDevelop issue, with and without the resize action. Maybe it’s linked to your Linux OS.
  • As far as I see, the loop disappears because it is rescaled to 0: 1 - 0.8 - 0.6 - 0.4 - 0.2 - 0
1 Like

If you can, can you report it?. I am currently not on my computer. Do you need any screenshots or any video footage of the problems and the closing of gdevelop?

Sure, I’ll report it.

1 Like