Cordova build and admob

Hi all.
I’m using the locally installed cordova (v10.0.0) to build my app and I noticed that the admob doesn’t seem to work. When I use the online service through GDevelop the ads are working fine, when I build by hand, they don’t. This is the list of the plugins installed for the project:

steliosm@debian:~/SoccerBoard$ cordova plugin list
cordova-admob-sdk 0.24.1 “AdMob SDK”
cordova-plugin-admob-free 0.27.0 “Cordova AdMob Plugin”
cordova-plugin-screen-orientation 3.0.2 “Screen Orientation”
cordova-plugin-vibration 3.1.1 “Vibration”
cordova-plugin-whitelist 1.3.4 “Whitelist”
cordova-promise-polyfill 0.0.2 “cordova-promise-polyfill”
es6-promise-plugin 4.2.2 “Promise”

Any ideas what I could do?

Have you tried test ads?

No, I haven’t tried this with test ads. The app ID and ad unit ID are working fine and I get to see ads when exported through the online tool but not through my cordova installation. DO you think test ads will help debug this?

Just tried the test mode in the ads and still getting no ads displayed on the app.
@4ian can you share the cordova /android platform versions you are using for the online build server?

This is equivalent to exporting your game and then doing a cordova platform add android - so it will be the latest Cordova version.

Thank you 4ian for clarifying that. I moved back to cordova cli 10 and did a few test builds (which took quite some time after having to uninstall and re-install cordova and plugins to make it work as it should). I still get no ad banners actually, except for test banners and that not always. This lead me to try to see what is going on using chrome inspect tools. What I noticed is that for the exact same built of the app, I don’t have the same behavior. In the first screen when the game start, I get an iframe which is trying to load the code:

Quitting the game and starting again, I don’t get the iframe this time:

Restarting the game a few times, doesn’t bring the iframe back also.

Some additional notes about how I load the banner:

I am using 3 scenes in the game: Start, Game, End. The banner is loaded and displayed on the ‘Game’ scene, after you hit ‘Start’ on the ‘Start’ scene. Moving the banner loading to the first scene didn’t change much.

Anyway, I might try downgrading the admob plugin and giving it another go at some point.

Thank you.