Create an object action not properly working

I’ve been tasked with making a simple shooter for a school assignment and I have had some serious troubles trying to create projectiles from my weapon. I have followed the basic code from the Tank shooter tutorial in order to make my character shoot, and it has not worked at all. I’ve tried replacing my bullet for different objects, I’ve tried changing the mouse button or key required, and nothing happens still. I checked the debugger and objects ARE being created, but just never showed up. I’ve given the bullet higher Z orders to try and fix this and I still cant seem to get it to work. I’m completely out of ideas at this point, if anyone has any ideas, please let me know.

you may have entered a parameter incorrectly in creation. may be it isn’t the correct layer. but this is usually the Z order used to be. check again your settins. may be post a screenshot from this events.

Here is all the important stuff I have as of now. It is very very basic. I have to put one image per comment because im new :expressionless:


Maybe you should upload your proyect folder. :wink:

you didn’t give Z order at all. please do some tutorials, before you ask clear things.