Create Object event not working for any object?

Hello again all,

I’m getting further along in my test platformer I’m working on. I’ve gotten past the weird animation issues I was having, have configured a camera that follows the player, and even have monsters with their own HP/damage before they die.

However, I want to have the monsters be replaced by a fire animation after they die. I followed the tank game tutorial to try and create an object at their location using the fire animation. Unfortunately, no matter what i try, the create object event never seems to fire.

Placing my fire animation object (set up as a sprite) in the map itself has it render fine, so I don’t believe it is the object.

Additionally, even if I just use fixed X/Y coordinates, and remove all conditions, the object is still not created. I have also tried choosing a different object entirely, just to be sure.

What’s bizarre is that if I run the debugger, the instance of my object IS listed there. It’s just not visible in the game? (screenshot here:

I tried searching the forums, but “object” is ignored when searched. Attached is a zip of my project. Any/all help is greatly appreciated.
CastlePlat.7z (406 KB)

I think “Z order” will be your friend :slight_smile:

1 Like

Thanks for the hint. This does appear to be z-order related. How do I make it spawn at the z-order I want? (in my case, 4)

Edit: Whoops. Looks like I didn’t realize events fired in the order they were listed in conditions. having the Do =4 z order of deathFire after it is created fixed it.