create object not working?

currently trying to make a simple shooter-type game, but for some reason using an event as simple as “when z key is pressed, create object at player.x() player.y()” doesn’t work.

I’ve tried changing the condition and also changing the position to stuff like 300 300, so I know it’s neither of those. I’ve also already tried using other objects, so I know it’s not that either. I also don’t think anything is conflicting 'cause the only other stuff I have is a really basic movement script.

if anyone could help it’d be much appreciated!

oh, forgot to mention that I’m using the sprites that come with the engine so there’s no weird image file stuff either

Try to change the zdepth of newly created object right after creating it. It may be showing up behind all other sprites.

Yep, that was it. now I just need to figure how to do that.
I figured it out, thanks kalel!

Also, think to take a look when it happens to the debugger : you’ll see the objects list on the scene, the layers and zOrder of the objects.