Death animation - Why won’t delete object?


After Death animation, it should delete the enemy, but it wont delete it.

I really dont understand why ? please can you help me

I have also checked other topics here, but still didnt help me :frowning:

Thank you

Hi, try separating the two events. The second part should not be a subevent.

Also, it’s not a bad idea to have the “slimedead” variable be an object variable instead of a scene variable.

1 Like

you have to move the second block to the left

1 Like

thank you all, i will try that today. and let you know if is works.


it does not work.

I tried also this:

this delete enemy immediately, and does not play the animation.

i have also tried this:

this works:

but I added that enemy is constantly jumping, which does not suit me…

when i removed jumping function:

then it does not delete the enemy, although it displays the animation for a split second

I really dont know what i can try more


Which values has the variable

after the dead ?

1 Like

Just to call out here: if you are using animation is finished to trigger an event, make sure it isn’t a looped animation.

Looped animations are never finished as far as events are concerned.


it has no value after dead.

ok. dead animation is not looped.

It’s very strange. It seems that this conditions doesn’t work.

can you test it alone? I suggest you to insert the debug pause as event


I have managed to have working animations, please see:

this is the only way, in which everything works.


1 Like