Default platformer controls off makes my player character not able to move

for some reason when I remove default controls and try to customize the controls myself it doesn’t work for me
any solution?

Hello, Protoman

Can you share the events that get your player moving?

Disabling default control disables up down left right arrows movement
If you want to edit it install remap controls platformer or topdown and there adjust your controls

Also RARELY you will need to disable default controls even when you make custom controls
Because well even if you move with WASD what’s the problem if you ALSO can move with arrow keys?

look when I meant customizing it like I meant using anything but the default control
for example using wasd to move while the default controls are disabled many did it and it worked for them I did the same but it didn’t work for me for some reason


Did you use behavior i mentioned?

Can you explain in more detail what’s not working for you? When you press “a” or “d” does the character just not move?

I did a simple test to check the right and left movement and it’s working perfectly here with the default control disabled. I’m testing on the latest version of Gdevelop 5.3.181.

Maybe there’s something else at your events that’s getting in the way of movement?

when I press them he just turns left and right

here is more of my code I hope you will find me a solution

I don’t know what it might be. Maybe there’s something very specific interfering with the movement elsewhere in your code, but I confess that I don’t know what it could be given that you say that with the “Default controls” enabled the movement works…

I believe that by following the orientation of @ZeroX4 and using the extension BehaviorRemapper you were able to solve it, but I think it’s very strange that it’s not working… :thinking:

Can I make one last guess? Delete the right and left simulation actions and re-enter them. Are you using the latest version of Gdevelop 5.3.181?

And just to be clear: the option “Default controls” allows you to use the arrows without having to configure them. In your code, you’re using the “a” and “d” keys, so, your arrows won’t work if “Default controls” are disabled.

Yes I know the arrows won’t work when I disable default controls that is why I use WASD for movement and yes I use the latest version of GD
And alright imma try out those extensions,

was trying to finish at the very least the demo of my

game but due to me being a bloody beginner and having a lot of circumstances in my life as well as

me living in a terrible 3rd world country, and I be feeling that my fellow friends would think I’m slacking lmao
I know this is irrelevant but I liked to confess it sorry xd

I just tested this is working normally by making a platformer from scratch with just a character and a platform, disabling default controls, and then setting up custom controls. Everything worked as expected.

Just to double check, do you have the actual platformer character behavior on the hitbox object, and not another sprite?

I checked and yes it has it