Does GDevelop have the ability to fade music to 0 in a scene?

I’ve tried all the fade music and fade sound options. Nothing is working?

Can you show what you tried? Note: if a sound is played after the fade has started. I believe it will reset the volume. In that case, you’d have to either prevent new sounds, use a variable for the sound parameter or fade the global sound volume with something like a variable tween or an extension if one exists for it. I could be wrong; I don’t believe the global sound parameter has an action for fade.

This would use a scene tween (under other conditions and other actions) and the space key.

edit: This would probably be better. it uses the current volume instead of 100.

Hello. This is what I’ve tried. I’m just simply trying to fade music out so I can start a new music file.

It looks like this code is working in a new project, so my original game project must be interfering somehow. I wish someone could take a look at it.

Is anything else playing on sound channel 0? If you’ want to just fade the one sound or music then I guess just make sure it’s on its own channel.

1 Like