Does not show ads

There was a problem with the ad display. While the scene is running, I upload a video with an ad

then, when you click on the desired button, I start displaying the downloaded ad

but the ad doesn’t run. after clicking on the button, nothing happens. In the test mode, the video also does not load. what could be the problem? Maybe I’m doing something wrong?

Try on your mobile device.

after exporting, no ads are displayed on my phone

Not completely sure but just trying to help out with some suggestions. :slightly_smiling_face:

Have you tried with action: display automatically when loaded: no ? (That way the video is being loaded in the background and ready to be deployed when the cursor is on touch)

Or have you tried with just the condition:
The cursor/touch is on ads
Trigger once while true
(Maybe there is something with one of the conditions)

Show the loaded reward video

Dont know if it maybe could be that there is both interstitial and reward video at the same time. Maybe that is messing things up.

Thanks for the reply. I turned on the automatic activation of ads after loading, but it didn’t help. After that, I decided to take a little rest and not continue the project. After a couple of days, I just launched my game and the ads started working. It looks like AdMob didn’t want to run ads for some reason.

This seems to be normal behavior. As mentioned on the wiki, new accounts or apps will take a few days before ads will start populating.