Effect that effects multiple layers

Hello everyone
I have a small problem. I’d like to use this CTR-filter effect, but I have objects on multiple layers. I can’t put the effect to each layer either, because that would intensify the effect on overlapping places.

So, I’d like to only use one filter “above all layers”. Or under everything and let it shine through everything - you know. Same thing.

This has been asked before and the answer I found was that it is currently impossible. But this answer was given few years ago and I’m asking whether thing have changed.

Thanks :slight_smile:

Never used the CTR-filter effect, but I assume you can just turn it off and on, e.g., set a boolean. So, maybe set a scene variable or maybe even a global variable (boolean) to enable and disable the effect with whatever your condition is. But I’m not sure what condition you’d use to trigger it for one particular filter.

Sorry but I don’t understand your point. I can able and disable effect with no problem. The problem is that effects are tied to a specific layer. I need the effect to affect every layer.

Hi,
I think there is nothing you can do with the layers. The only possibility would be to assign the CRT effect to each object individually. Depending on how many objects you have in your scene this could be quite tedious and maybe also performance heavy. But maybe it is worth a try?

As I said, the overlap causes the effect to intensify in certain places and it doesn’t look very professional.

Cant you just put the effect on the top-most layer or I am missing something?

Unfortunately it doesn’t seem to work. Let’s say the top-most layer has only the player character. If I then add the effect to only that layer, only the area the player character occupies will the affected. Assuming the character is always in the middle of the screen and small, you’ll only see CTR stuff above and little bit around the player.

What if you add a giant object with opacity 0 (or hidden)

1 Like

That’s why I suggested to assign the effect individually to each object instead, not to the layer.

If you go to edit object there is the option to add an effect. Not all options from the layers are available there but your CRT can be selected. If those objects overlap they don’t interfere with each other but of course the overall look is different and probably not what you want.

1 Like

Oh! I see. Each object. I’ll investigate that. I didn’t realize you can set effects to objects.

If the effect should be visible across the entire screen, then Reborn’s idea is worth a try. Opacity 0 is not working though, but maybe a slightly higher value will do the trick.

Not sure what’s being asked here, as the CRT effect will apply to the entire screen if you put it on the top most layer.

This is the not-a-vania example, with the CRT effect on the GUI layer only. It’s still applying to the entire visible space for everything behind it. There are 7 layers in this scene, including multiple layers of backround. They all get the scanlines and grain on them.

The only thing that won’t work is if you have a layer with nothing on it at all (0 objects total on that layer), because then the layer doesn’t have anything to indicate it needs to render, as far as I know.

strange. It didn’t seem to work like that when I tested. I’ll do some more testing