Error message after click/touch

I noticed this error in the intel xdk bug tracker and also in the chrome developer console. I reverted to the last version of GD but the error still appears. It appears the error occurs a lot more when switching scenes and/or restarting a scene.

Refresh your webbrowser cache (Ctrl+F5 / Alt+F5 or Shift+F5 depending on the web browser). :wink:

I cleared the cache but the error still shows up after clicking on the option to switch scenes. If I run the project in Intel xdk the bug tracker console shows errors with every use of the touch/button click event not just on the scene switch buttons. The shot bellow shows the error console in the intel xdk.

And outside the XDK ? (in a web browser)

The same error shows up in chrome after clearing the cache.

Does it causes problems when executing the game ? (In fact, it’s not related directly to GDevelop but to a lib that GDevelop uses).

If I switch between scenes 6 or 7 times the game becomes unresponsive to clicks. Since noticing the error all apks compiled in xdk fail as well. If I run it in firefox I don’t notice any unresponsive click issues.

I tried the project on a different machine and after 21 of the same error codes coming up the touch/click interaction stopped working.

I have downloaded your project from the Games Showcase, and noticed the bug. Try to deactivate the Draggable automatism before deleting the object being dragged (the food and the ball, I think), other way it seems that the automatism fails :wink:

Let us know if the error persists :slight_smile:

I added the automatism activation/deactivation, thank you for the suggestion. It seems to help with some of the errors but I notice the same error comes up when I switch scenes. I created a test scene that shows the same error, if you click on the red cube text appears and if you click it resets the scene. When you click on the blue cube the error shows up. (2.65 KB)