Expressions pipe operator

Often when writing expressions, specifically when working with strings, expressions can get quite lengthy and confusing to read, making it hell to write and change later on. My solution, a “pipe operator” that would pass in the evaluated expression on the left side as the first parameter of the one on the right side.
For example, if -> is that pipe operator, those expressions would be equivalent:
ToString(Variable(MyNumber)) and Variable(MyNumber)->ToString()

This allows to make some stuff way more readable:

StrRepeat(ToLowerCase(SubStr("MySuperDuperString", 0, 3)), 3) could become SubStr("MySuperDuperString", 0, 3)->ToLowerCase()->StrRepeat(3)


I think is a good idea like in PHP Object oriented.

Indeed this could also help make object oriented extensions

Well now I have a problem I have multiple feature requests like this one that got a few likes but I don’t know if it is enough to continue to the next step and if the next step should be porting it to github or beginning to write an implementation