Floor Not Showing On Preview! (Still working as platform)

Hi, me again. Well I’m almost done with my 5 level minigame, I just have to add the menus and stuff.
But turns out, for some reason the floor in my last level doesn’t show on the preview. Instead there’s just black space, but still working as a platform.
It happened once before, and I just delete it and create it again with a different name, even though it’s a Gdevelop tile. That time it worked but now it happened again, and this time I tried the same thing and nothing happened.
Does anyone know what could it be or what can I do to fix it?
Please help TT
Thank you.

Check the floor and background are in the same layer then check the floor z-order to be a value higher than the background sprite.
Also check if the floor has the behavior Destroy outside layout

Yes, yes I cheked all that and everything was right, the z order, the layer, no other behaviors apart from “platform”… Plus it did work before, I mean, the floor is the first thing I put in the game and tried it. It just suddenly stop working.
Anyway I tried to add it again, since I’ve changed the name, I just went to add new object and add it again and now it works. Wich is great but still don’t understand why it happend.
I had to do the same with another platform that weirdly worked as a jumpthrough in the first part of the level (wich is what I wanted) but not in the last part. The same platform, not even a duplicate… The same one wasn’t respecting the same behavior in different parts of the level.
But as longs as it works, just let it be a mistery… Thanks for your answer.

PS: I’m making this as a gift, I’m not a game developper, I’m a tattoo artist.

Nop, it’s not Solved, now its happening again :frowning:

If the object is REALLY long or big it’s possible the engine could be culling it from view… maybe.
I would suggest putting your background on a different layer, and then hiding that layer in the layers section and see if that helps isolate the issue.

Thanks for the advice, I’ll try it out