Game Building/Export Error. Size Limit?

Hello everyone,
I have had a Gdevelop subscription for 4 years and use it weekly. Since the last newer versions, I get more and more error messages when exporting/building. I can’t get my latest game (arround 700 MB, my previous games have the same size) exported at all (see screenshot). Has Gdevelop introduced a limit for file sizes? What can I do?

1 Like

It seems your build has timed out, meaning it took too long and the server gave up before the end.
Can you confirm your network uplink speed (how much time does your computer need to upload 700MB)?
Does it time out during the upload or well after ?

Thank you for your feedback. My download speed is 250 MB per second, the upload speed is 40 MB per second. The error message appears after completing point 3 “Build and download”.

In the meantime, I had one successful export. I also tried to export a smaller game, which worked perfectly. So in one day I had 1 successful export, 9 failed. Apparently there is an unofficial file size limit? Maybe GDevelop could communicate this?

For as long as I’ve been using GDevelop (~2018), the maximum upload size for the online build server has been ~100-250mb, anything past that will give you a rejection error (error code 500) or outright timeout.

As far as I know this is intentional due to limits from the various hosts involved. Anything larger than that you would need to build locally rather than use the build service.

The strange thing is that my first games were exported despite their exe size of up to 600 MB. Apparently, the limit has been reduced considerably in the meantime. Well, I’ll try to make the file a little smaller, and if necessary create the game locally manually. Maybe in future GDevelop versions the hint can be displayed that the online build service only works up to 250 MB?

I agree with this and have forwarded it on to the devs. If nothing else I’d like to see it listed in the Wiki.


Would you like to recommend me please a tutorial video that best shows me how to build the game manually?

Hi there,
There is no hard limitation on the build service for Windows for the moment.
However, like every service, it has its limits and it’s possible that it reaches its maximum allocated capacity.
We take the point on making the errors/warnings more visible in the interface, we can and will definitely improve on that.

For your problem, I could see multiple causes:

  • Either it is indeed too big for the service, so you can try building it manually on your machine (take a look at electron-builder)
  • Maybe one of your files is too big or of a format that the packaging service consider corrupt. If you’ve recently added an image/video/something else, try to remove them and launch a build again to see if it fixes it?
1 Like

After deleting some scenes and image files (150 MB) and 17 official building attempts, my export remain unsuccessful. Because of the lack of reasons behind the error message, I tried to build the game manually. Unfortunately the tutorials are not really clear, also because some software has to be installed and this leads to different results workflows on each computer. My project is very important to me, a lot of time was put into it, now I would like to ask openly if someone can please build the game manually for me? If necessary, I would also pay a fee for it.

Hmm, it worked now: in the preferences I changed the title from “Cowboy Bebop: Nope” to “Cowboy Bebop Nope”. Is it really possible that the file could not be built because of the “:”? The story behind the game is almost now as strange as the building.

Anyway, big thanks for the support, which once again made me think about all possible and impossible mistakes and errors.

Unfortunately, non-alphanumeric characters are known to cause issues, and I avoid them as much as possible.
Such issues have been fixed here and there in GDevelop, but maybe some of them remain. If you add the pesky character again and it fails again, I guess you’ll have your answer.
Either way, glad you managed to build it, looking forward to seeing your new project. :slight_smile:

1 Like

Here you can find it: