Gamepad release buttons not consistently working?

Heyo! So I decided to set up a controller for my game but I’ve run into an issue that I can’t seem to solve.

What’s suppose to happen. Player Holds down button, time is slowed and when the button is released the player uses a super move. This set up works fine 90% of the time but randomly (can’t see any patterns) the button does not release, leaving the game slowed down and no “super” happens.

This is the Super move events

This is how it slows down time, separated for different supers

Also have this event, that moves the supercircle around for placing it.

It’s weird, I have the same set up for Mouse pressed/released and have never had an issue…
I tested a few controllers, same issue. any help is appreciated :slight_smile:

It may be because you are duplicating your conditions.

The gamepad api doesn’t know RT or R2. It knows button 7. Both RT and R2 are actually Button 7 on the api.

The Gamepad extension does some translation for you because people don’t know the button numbers directly, but it is just a translation. If you have one condition for RT, and use a pS4 gamepad, pressing R2 will work

All of the above in mind, it may or may not fix your issue, but I would recommend removing the “or” entirely and only use one condition, for RT or R2, but not both.

Just tried and no luck :frowning:

happened about 8 times in 350ish tries, still feels completely random when it happens

Hmm… Maybe try using the “pressed” condition and invert it, instead of “released” (just make sure you also have trigger once as a condition)

hmm no luck, once the super charges it just uses it right away.

I can’t seem to pinpoint anything that causes it, it’s so random on when it doesn’t register…

I’d recommend showing your updated events here. I’m out of ideas but others may spot something.

So i did some tests with the event below. Click 50 times and twice it didn’t add to the test. Also had R2 is pressed set up and that one seems to work every time.

Gonna start a new project and see if it still happens.

Made a whole new project, set it up to count on press and release, clicked 337 before I saw the same issue. Still could be a controller issue, but happens to often in my project :frowning:

happened twice in 900 clicks

So I solved this by removing the “button release” and adding 2 boolean variables. Triggerpressed and triggerreleased.

After testing the button released in a new project over 5000 times with different controlelrs & different playtesters, it wasn’t perfect, which isn’t ideal in my game. I’ve tested the 2 boolean methods over 3000 times so far and no issues.

I think the button release may be buggy? tested in 2 different projects and same results.