GDevelop 3.6.79

GDevelop 3.6.79 is available!

Here is the changelog, copied from the GitHub release page:

Added German and Portuguese translations (still unfinished, about half of the software is translated: help us on
Full support of multitouch for HTML5 games. Use it simply with the “Cursor/touch is on object” condition, or create custom logics with advanced multitouch conditions.
Added actions to change animation speed.
Added CurrentSceneName() expression to get the name of the scene.
Fixed ToJSON expression not handling quotes properly.
Added previews of images to some “open file” dialogs.
Fixed crash with large tilemaps
Added Slot machine example (thanks to Erdo)
Added multitouch example
Minor User Interface improvements.
Internal work to support Mac OS X.

Ubuntu and Linux users can get the update by upgrading from the PPA/repository, that should even be done automatically :slight_smile:
Windows users can download it from the GitHub page:

If everything is ok, I’ll make activate the software update to make it available for everyone :slight_smile:
Their have been some internal changes so please tell me if anything broke with your games. And remember to make backups! :slight_smile:

Updated on Ubuntu 14.04 and Debian 8. No problems up to now!
Tomorrow I’ll test “Tojson” and multitouch.

Thanks again! Nice Improvements.

Cool, that’s great! What did you use to get it working on Debian 8? You compiled from source or got it from the PPA? :slight_smile:

First time compiled, but did not work… so, for curiosity I’ve installed from PPA and worked.

Ok! Surely something missing for the compilation, if you tried again later, just post an issue on GitHub ( so that we can help to compile it on Debian. :smiley:

It’s cool that it works on Debian, note that it may break one day but well, this is a good surprise :slight_smile:

Yes! But from PPA there’s a “trick” to add PPA on Debian and make it work:

1) First, in Debian things are a little different, so we need to install this first:
apt-get install software-properties-common python-software-properties

2)Than add the PPA:
add-apt-repository ppa:florian-rival/gdevelop

3) After that, you need to edit “sources.list” and change “wheezy” to “trusty”

The last step is the same…

apt-get update
apt-get install gdevelop

Yes, I’ll try to compile again in a few days, but it was not an error from gdevelop sources, but from my libraries to compile it. With no much time to try to discover the missing ones, I’ve decided to try from PPA.

This is the screenshot from Debian:

I have tried to download the twice but I get “file is invalid” error message when I try to open it.

Could anybody else check it? I just download it and extract it with 7zip without any problem it seems!

Well! Here in Ubuntu 14.04, I’ve downloaded this “” for windows, and opened via WINE.
Guess what?! It works!

It works via WINE. I did not tested examples, or opened files, but… opened without warnings.

Normally I can simply open zip files in windows and extract it that way but it doesn’t work with this one.
I have no such problem with other zip files.

The excessive CPU consumption in event sheet bug on linux is still there

I will wait till its fixed. My laptop really doesnt like gdevelop, especially with a web browser opened as well.

I’ve downloaded it (windows this morning and works fine :slight_smile:

with the WIndows Problem ddabrahim, have you tried to download it again, maybe it was not downloaded correctly. Another try could be rename the file before trying to extract it( cause you have two dots there and I do not know how windows read it ).

With the problem in LInux, blurymind, I use LInux here too, and for me, it happens when Try to preview. But after some minutes it decreases the cpu usage. But there is a “trick”… you can try to limit cpu usage by Gdevelop. Maybe it can help you until this bug can be correct( I khow it is not the right solution, but you can try to save yourself for now).

Take a look at this:
and this:

The zip file is a bit steange : it opens only with 7zip or winRAR and when opened, only two files have a non-compressed size different from 0.

Yes, here on Linux I’ve extract files, and than recompressed using ZIP option, and the regenerated Zip file has 3x size than the original one. But it works.

If you want I can upload and create a link to download this one(the extracted and recompressed one ). Let me know.

Guess I have to repack that zip again, that’s strange what’s happening.

cpulimit does not limit the cpu usage unfortunately.
When you run gdevelop, it actually runs another process called “GDIDE” which consumes the cpu when in the events tab.

I dont know for you, but for me it consistently eats over 50-57% of the cpu when in the events tab. It doesnt stop.
It is obviously the events tab.

Ok i was able to limit the cpu to 20% by editing the startup script:

[code][fox@darkstar ~]$ cat /opt/gdevelop/
#Execute this file to launch GDevelop
#If you can not launch GD, make sure that this file
#as well as ‘GDIDE’ have the right to be executed
#(Right click on file > Properties)

if [ -z ${1+x} ]; then
cpulimit -l 20 ./GDIDE
cpulimit -l 20 ./GDIDE “$1”

if [ “$?” = “127” ]; then
mkdir -p ~/.GDevelop
./GDIDE 1> ~/.GDevelop/errorMsgWhileLoadingGD.txt 2> ~/.GDevelop/errorMsgWhileLoadingGD.txt

errorMsg=$(cat < ~/.GDevelop/errorMsgWhileLoadingGD.txt)

echo "$errorMsg" | grep "loading shared"
if [ "$?" == "0" ]; then
	zenity --error --text="Unable to launch GDevelop! Here is the error message:\n\n <b>$errorMsg</b>\n\nMay be a <b>package is not installed</b>.\nCheck if you can find the package in the Software Center.";
	zenity --error --text="Unable to launch GDevelop, a unknown error happened! Here is the full error message:\n\n <b>$errorMsg</b>\n\n.";


However, then I get the problem where the events tab is super laggy! :frowning:
And gdevelop is obviously running slower.

Also it leads to html5 games no longer working. You get this error in the browser

Error 500: Server Error Client closed connection

limitcpu is not a solution.

The editor is really badly optimized.

(So, optimize it better than ourselves…)
The problem is that I wasn’t able to figure out where the consumption comes. If GDevelop is much slower when its speed is limited, it might indicate that it needs to work at this speed and you still have one full core available for other tasks.

Out of curiosity, what CPU do you have? Sounds like you have dualcore which is seriously a no-go these days - you want at least quadcore to run complex applications.

Also, could you download Windows version of GD (it can be ran via Wine) and tell if the problem still occurs then?

//edit: As of optimizing, this is pretty much my guesswork, but first thing I’d suspect is event tab’s rendering function. Perhaps it contain some loops you could get rid of in favor of rendering it in a single pass?