Gdevelop black screen

What’s going on with gdevelop?
This is not the first time this has happened.
When starting the game (debugging), a black screen appears and nothing else happens.
I run Gdevelop in the browser.

Может с другого браузера запустить или установить платформу на комп и с нее запустить?

I tried FireFox and Chrom, and both had a black screen. But it works through the app.
This is all strange.
Thank you.

My two ideas:
try to comment all the code before to run.
Is it possible that you put a breakpoint ?

It seems like we’ve already decided. If you run it from the application and not from the browser it works

The fact is that the code here currently works in the browser. I didn’t change anything, it worked on its own.
This is not the first time I have had this problem.

Everything is working now. Apparently there are some problems on the Gdevelop side

A few things to note:

  1. There have been no updates to GDevelop’s code pushed to production in 3 weeks. If it is randomly working again, nothing was changed on the GDevelop engine side.
  2. Generally Firefox does not behave well 100% of the time with WebGL, if you see oddities you should try on Microsoft Edge or Chrome.
  3. Multiple errors in your log seem to indicate that the renderer is getting bad/garbled data. You might ensure you don’t have invalid resources in your project resources panel, or anything with invalid filenames (a-z only, 0-9 only, - or _ only)

Outside of that, I’m not aware of anything that would cause a black screen (barring you having a GPU that is blacklisted from WebGL support (browsers change their blacklists occassionally) and are using effects that require it, so the canvas fallback doesn’t work)