Gdevelop not Updating

I am a beginner game dev trying to update gdevelop to the latest version (5.3.199). But the auto update doesn’t work.

Everytime I load up gdevelop it says a new update is available and it will download it automatically when I close the program. But no matter how long I wait and open it again it just says new update is available. I had downloaded the setup when the version was 5.3.194. And it properly updated until the version 5.3.198. But then I can’t update it to 5.3.199 which is the current newest version. It says “ERROR WHILE CHECKING UPDATE”. There is another post about this but that didn’t work out. I haven’t disabled anything in preferences, yet it still doesn’t work. can someone help me?

Try making sure you have an active internet connection, andif it still happens, try re installing it amd try the update again

1 Like

Hello, i am a french old lady and i don’t speak english. But i try to do an answer. I have a same difficult with the latest version (5.3.199). The prewiew doesn’ work. And it says error of editor. So look at the events. if something is (inderlin) red, do “suppr”.
Have a good day, and take heart

1 Like

I reinstalled and the newest version which was 5.3.200 That day. Then updated it to 5.3.201. It worked. All I need to do was reinstall the program, thanks alot