Get objects to draw from origin

Why does my preview not match the scene editor?


The pine tree seems to draw from the center in the preview. Other objects seem to match the editor. I have not modified any points, origin is 0,0 and center is auto, auto. Tried deleting and re-adding the tree which did not help. Anybody have any clue what is going on?

Played around a bit more, I don’t see the issue if I create a new empty project and add the same object from the asset store.

I suspect the issue is related to my other issue with custom sizes: Preview broken in ios app - #3 by giannpls

It seems like maybe the project got corrupted but I can’t find any obvious issue in the json data when I save the project locally on PC. Does anyone have any ideas on how I can fix or recover the project?

Hi giannpls, interesting problem, I’m looking forward to reading what the solution is. Have you tried other things, like moving the tree to a different position? Or moving the shape painter which I assume is for the pathfinding to a different place, like even out of the display area altogether?

Update, I hadn’t seen the above post when I was typing. Yes indeed definitely something strange going on as mentioned in your other post.

Seems like the center point is not being calculated correctly, when I print the origin and center to a text object they are practically the same
Center is using auto coordinates

Event sheet

Somehow origin and center are practically the same. It seems like center is being calculated as if the width and height are 1px. This may also explain why the object becomes huge if I enable custom size.
EDIT: confirmed and updated screenshots, the width and height of the object is somehow 1x1

So far this issue happens in iOS app and iOS web editor but not the PC app. All are reporting 176 version

I think I was able to figure this out. The problem seems to follow the resource URL. Project resource works on pc but not iOS: [ tree5.png]( tree5.png)

Asset resource works on iOS: [ Backgrounds/Plant/69602b67c402fce71ac360d8b50f0933dd362a40e12318bfb77e5e5b88d98c54_Pine tree.png]( Backgrounds/Plant/69602b67c402fce71ac360d8b50f0933dd362a40e12318bfb77e5e5b88d98c54_Pine tree.png)

I am not sure how I ended up with the project resource link, maybe when I saved the project locally on my PC and then saved it back to the cloud. Deleting the object without deleting the resource and then adding the object again did not fix the issue. Deleting both the object and the resource and then adding the object again from the asset store seems to fix it. I’m still not sure whether there is any difference between the files, they look the same when loaded.