Get the inbuilt Piskel app to work correctly?

It was working fine at first. I exited the piskel app so I could put a little sprite on the screen, animation working, so far so good… I wanted to start drawing something else, and this happened:

Any tips on how to fix it? I tried right clicking to see if there was an option I’d hit accidentally or something, Also, when it was working, the select tool doesn’t work properly.

If it is not possible to get piskel working as intended, is it possible for me to draw my artwork in Krita and then import it? I don’t think Krita does animations, but I can make a sprite sheet containing the necessary frames.

GDevelop (and Piskel) both do not support being stored in a location actively being synced by a cloud storage application like Onedrive or Google Drive. Windows will prevent Piskel from being able to create it’s temporary file, which leads to what you’re seeing.

Try creating a folder directly on your C drive named “GDevelop Projects” or something similar and make your projects there, it should be able to create the temp files needed and work then.

You can make your assets in any art tool you want. Don’t click the “Edit” button, instead click one of the +/Add buttons on the sprite/etc.

It hasn’t worked :slight_smile:

You can see the path at the top, which is, as you suggested, directly on the C drive and shouldn’t be syncing to onedrive

I might uninstall and reinstall GDevelop to see if this helps, if it doesn’t I’ll just do my work in Krita

A completely fresh install solved the problem, it is now working as it should! Hopefully now I know where to save the game data, it won’t happen again.