Have option to disable animations in GDevelop editor that aren't affected by system "turn off animations" setting [Accessibility]

  • What: Have option to disable animations in the GDevelop editor, such as:
    – when opening project manager,
    – the Android-like circular effect when pressing any button
    – the fade-in when you open an always on top window such as Preferences or Global Variables
    – the Preferences tab’s highlight bar moving when you switch tabs
    – the loading circle (previewing, loading stuff in the Play section of the Home tab) - I would rather it be a static image or just a “Loading…” text

I hope the GIF explains well enough.

Some other animations do respect the setting after a reboot, like editing the parameter of any condition/action. That was where most of the problem was coming from, but the others above are still there.

  • Why: Because animations are frustrating for me to watch, and it makes me tired quicker.
    My computer is a little outdated, so often I have to fully watch the animation play out before being able to do what I wanted to do (for the project manager sliding in atleast).
    These may seem nitpicky, but the frequency of the animations adds up and at some point just using the program gets stressful. (side note: I don’t think the issue was as noticeable when I was still using build52 a few years back)

In comparison, while Windows 10 has a horrifying amount of animations, I can still use the computer without issues as I can disable their animations by pressing Win + U > Display > Turn off Animations (pictured).

Turning off animations in any program (Firefox’s auto-scrolling as another example) always makes me happier.

As GDevelop is a web app, there is a possibility I just didn’t turn on the correct setting somewhere. If so, please advise.
Thank you for your attention!