Help! Installation - Development version of GDevelop

Help, so I’m trying to open the development version of GDevelop to use a couple of Cordova APIs. However, I’ve run into an issue and I can’t see to find out why.
What I have done:

  1. Installed node.js, Git and yarn.
  2. Created a folder called MyGdevelopFolder in C:.
  3. Opened the cmd prompt as an admin and changed to directory to C:\MyGdevelopFolder>
  4. Cloned the Gdevelop files with C:\MyGdevelopFolder>git clone GitHub - 4ian/GDevelop: GDevelop is an open-source, cross-platform game engine designed to be used by everyone.
  5. Then changed the directory to C:\MyGdevelopFolder>Gdevelop/newIDE/app
  6. install npm i.e. C:\MyGdevelopFolder\GDevelop\newIDE\app>npm install
    My install npm fails (see attached image)

Would anyone know why this is happening?

Thanks in advance!

Have you checked that the folder structure of your MyGdevelopFolder is as expected?
You seem to have missing files errors.


From what I have checked, the folder structure of MyGdevelopFolder appears alright. I’ve tried recloning it too. Could the missing files be due to the files that have failed to be installed earlier during the installation?

I’ve cloned “GitHub - 4ian/GDevelop: GDevelop is an open-source, cross-platform game engine designed to be used by everyone.” into C:\MyGdevelopFolder.
Changed the working directory to C:\MyGdevelopFolder\GDevelop\newIDE\app
and then C:\MyGdevelopFolder\GDevelop\newIDE\app>npm install . Should be easy enought. Would installing a specific version of npm help?

Thanks for your help! :slight_smile:

If files installation failed earlier, you should have seen error messages. Won’t hurt to reinstall, though.

From the screenshot above, it looks like even path change fails, perhaps a permission issue?
If you can share the full log file mentioned, it might be helpful.

I’m not experienced with this, I tried a few times and gave up. :person_shrugging:
Maybe @Bouh will know. :wave:


Yeah, I’ve tried multiple installation attempts, but haven’t managed any progress.

Here’s the full log:

Thanks a lot for having a look at it!

I see your screenshot, to me Modules are missing in GDJS folder.
But I’m not really trustable I don’t know much about that kind of errors, if this doesn’t help you, you should better ask to devs on a Github Discussion I guess.

For information I use npm 7.8.0 and node v16.13.0, also I prefer using Yarn 1.13.0 instead of npm.

Ah, alright! I’ll try it out with the versions that you have. If that doesn’t help, I’ll check out with the devs on a Github Discussion.