Help with Admob (GDEVELOP )

Hello people :smiley: , i try to implement admob in my game , but it does not work for me in any way.
so I decided to experiment with the example of GDEVELOP , but the example does not work for me. the banner does not appear nor the intertitials, I do not know what I’m doing wrong, I’m following the steps of: :confused: … ures/admob

But it does not work for me, does anyone know how to make it work? :confused:

hi its working for me. You need the admob.code for your app.
The ads dont show in gdevelop previrw only on apk running on Android
If you want you can post code here.

thx a loot to reply :slight_smile: , i use the id app-admob and the id banner to try show the advertising, but no work the code.
i try with the name and ide i use “” and the code like the example in the texbox show a banner, in theory it should work but it does not work. and i try a new banner and new app program in admob too and remains the same,I do not know what I can be ignoring.

i upload a screenshoot of my code to so that they orient me better than I am doing wrong, thx

Some points:

  • The AdMob application ID (the one you write in the project settings) must be entered without quotes :wink:
  • Ads won’t work at all on preview nor web export, only on Android builds :slight_smile:
  • Finally, with the two changes above it should work, if it still doesn’t work you can try two other things: First, instead using “Test mode” in the ad loading action, use a test ad ID from here (a compatible one please, if you load a banner use the banner ID). The last thing I would try is using a fake AdMob application ID, instead your private app ID use any other value, in the admob example the value is “test” (without quotes), this is because sometimes ad IDs take some time to be enabled, it depends on the country so is a variable I want to remove.

If still doesn’t work (you’ve to try it on your phone) let me know so I can start checking the extension again, something may been updated :slight_smile:

Are you sure your admob configuration is complete? it took one day or more for my app to show ads. Check thas admob approbed your ads

hi thx to reply , the example works, but in my game not work.
i follow the paths step by step.
I do not know if it influences that I developed it initially in GD4 and I passed it to GD5 afterwards?

But even taking a day, when you opened the game, was there a white box in place of the ad? or had nothing?
Mine is not showing anything, I have the same problem, it does not show anything … :frowning:

can you post a screen capture of your game??
If you use the test option on gdevelop and compile you shoyld see an example banner, this works?