How can I input the song to the other two scenes while it continues to play?

Hello to all. I am merely a simple student seeking assistance from the Gdevelop community. I now have a problem in which the music that I wanted to play plays in scenes 1–2 but stops at scene 3.

Scene 1 (Music) → Scene 2 (Same Music Still Playing) → Back to Scene 1 (Still Playing) → Scene 3 (Stops)

A code I put to play scenes 1 to 2
condition - global variable "soundstart = 0
action play the sound ------- on the channel 0, vol 3.7 loop: yes
change the golbal variable: set to 1

That is the issue. So, kindly assist me in fixing it. Thank you very much.

If you right click on scene 3 and click on “Scene Properties”, make sure the “Stop music and sounds on startup” is unchecked.

Thank you, but yes i already unchecked it.

What are the music playing events for scenes 2 & 3? Can you provide some screen snips of them?

Some of the codes we put with my group mates are just trial and error so bear with the events :v

Scene 1 is menu

I cant put multiple emb picture so I will reply again

Scene 2 is play

Scene 3 is option

@MrMen I forgot that I added a volume slider in scene 3
I thought it won’t work because when I added it I didn’t configure it but still the problem is it won’t play or it doesn’t have a volume and it’s not maxed right slider volume.
I copied one of your replies to another question soooo heres the events


the music file is in scene 1 I wanted it to play at the beginning.

In scene 3, why are you playing the music on channel 1, but use channel 0 in the other two scenes? And does it really keep playing in scene 2? It’s got a Pause Music on Channel 0 action.

Sorry, we were doing trial and error, we fully don’t know how to use it. If you saw my latest reply I actually changed it. And in scene 2(play) yes it does play again.

This is scene 3


Pls bear with me xd

So where are you playing the music in those revamped scene 3 events? It’s only setting the global sound levels.

I copied one of your replies to make the slider to its max volume slider. I thought this would fix it because the slider is on the left which means it doesn’t have audio when I go to scene 3.

So likely my problem right now is how do I fix my volume slider?

Why don’t you just play the music in scene 1, and not touch it in any other scenes? Make sure all scenes have the stop music option unchecked. I’ve done that with a test project, and that works fine.