How do I not break the mobile touch controls after an interstitial or video ad is displayed?

Whenever an ad is shown in my mobile game and I exit out of the ad, the touch controls get very messed up. It’s as if the cursor is stuck and no other touch is registered after that. This causes all sorts of problems. Is there some way to reset or disable touch until the ads are done showing?

I’ve tried the “de/activate moving the cursor with touches” function and a few other things but have been spinning my wheels for hours.

I don’t remember reading other reports of this issue.
Have you tried other mobiles, other projects?

Could it be that some touch remains stuck? To confirm, you could use the multitouch actions and see if it helps.

If you were to disable touch, how would you exit the ad?
Do you need to move the cursor with touches? Otherwise, you should already be using that de/activate action.

Hi Gruk, I went back and completely reimplemented my touch controls with the multi touch and turning certain objects into buttons. It took forever but it worked. An issue does remain though upon exit and return to the game where the controls will sometimes get stuck. Also I think the touch controls related to ads are separate from the mobile touch controls so even when they are disabled, the ads could still be exited.

If you can share a template project demonstrating the issue, we’ll investigate :slight_smile: