How do I unsmooth the blurry sprites?

I can’t find a button anywhere, the UI is not clear.

Try Project → Game Settings → Resources. Click on the image name in the list on the right side, and make sure the “Smooth the image” checkbox is checked (or unchecked if you prefer) - it’s on the bottom left of the properties panel that comes up.