(I need help) Uploading Mac to steam?

I’m so frustrated at this…
First of all I managed to emulate Mac os on windows … version 10.12.6
I have a perfectly working mac on an emulator (virtual machine) and it’s with internet and everything.

so I was trying today to upload Mac file .zip from a test project exported from Gdevelop5
and I told steam to open the file named “game-macos.zip” >>> it doesn’t work

Then I tried exporting the file game-macos.zip and there was a file called proyecto.app inside
I uploaded that to steam and then told steam to open that file when I press Play on the steam client … it didn’t work, nothing so far worked…

So I did something else…
I downloaded Gdevelop5 on the emulated mac, exported the platformer project on the emulated mac… and it runs just fine, and it’s exactly the same file I uploaded on steam.
but it doesn’t work from steam and it works when directly exported from the emulated mac

What is going on?
How to upload Mac onto steam… why is it so difficult like that?
I need help with this…

Edit: I managed to get it to work but that won’t work … so in order for it to work from the steam client:
you need to open the .zip on mac and then it’ll export it self and then It’ll work but that has nothing to do with the steam client, this is all manual which is not a solution.
What should happen, is that people download the game, and then play and that’s it … but that’s not the case here unfortunately …

I’m missing something here and I don’t know what…

Not sure if it solves the problem, but try this:
proyecto.app is also just a zip file. Extract it and then you should get a folder called contents, inside that folder there is a folder called MacOS. This is where the actual executable lives, tell Steam to open the executable file inside the MacOS folder.

So, upload projecto.app to Steam and in the launch option enter:
proyecto.app\Contents\MacOS\launcherName

1 Like

Can you post the solution that worked for you when you find it please ? Thanks.

1 Like

I tried what you mentioned but didn’t work too, says running and then nothing.

But I managed to get it to work another way and it’s a super weird one honestly…
So I have this virtual machine that runs mac 10.12.6 with internet and everything.

@redcafe What I did:- (not confirmed yet that it’s 100% working)

1- Extract the game as Mac os as .zip file as normal from Gdevelop5
2- upload that .zip file on google drive (or any uploading service)
3- open the virtual machine >> open google drive (or any uploading service) >> download the .zip file you uploaded in the virtual machine.
4- double click on the .zip file inside the virtual machine
5- it’ll extract the content which is (for example) platformer.app
6- create a new folder >> put platformer.app inside the folder
7- again upload that folder to google drive
8- get back to your windows and download that folder.

That folder is your game…
You upload the whole folder to steam and enter in the launch option:
Folder name\platformer.app

And boom it works perfectly…
.
Now some notes:

1- If you extracted the .zip on windows and uploaded the .app file … it won’t run on mac when you download it there (yes it’s super weird), @ddabrahim if you have an idea why is this the case let me know.

2- The .zip file has to be on mac (virtual machine) then double click on it and then mac will export it and the exported .app file … this will work on mac, now all you need to do is follow the instructions above and put the .app file into a folder and upload to steam from windows … and you’re good.

It’s weird, annoying and bizarre and I don’t even know how I managed to get to that fix but I guess trying for more than 40 hours straight makes weird issue like this get solved, I need to sleep though :sob:

Now, all of this was done on a test project not the real game as it’ll take a lot of time to upload.
Next I’ll be uploading the main game and test if it actually opens on mac in the virtual machine.
If it does work then we have a solution, if it didn’t.
Then this solution is not correct and I hate my life :tired_face:
.
In a day or two (or a week it depends on how much testing I’ll be doing) I’ll get back with a confirmation on this if my game runs on mac with steam…

I would think it may be Gate Keeper on macOS prevent it from running as the App was downloaded from an unknown source. But not sure how and why downloading it in a zip and extracting the app from a zip or putting it in to a folder make it work. I would love to know why.

Weird, this is what they show in the docs:

Glad you got it working though, but it is dangerous to not knowing why is it working :rofl:

1 Like

@ddabrahim

This actually has a simple fix from settings then security, and there is another massege that says this file is from an unknown publisher and again it has a fix online with cmd but the message I get is something like “This app didn’t open because there was a problem” and it explain under it that you sent it to the developer to get another version or whatever, it’s very weird, it’s like it’s telling you that it’s corrupted but in a cool way I guess…

I have a theory, I think the way Mac os export .zip files is different from when exporting it in windows, I don’t know if that’s correct but it’s what I’m actually seeing from this.
If you export the .zip file in windows then try the .app file in mac, it won’t work.
But export the .zip file directly in mac os and .app works just fine.
It’s the weirdest thing ever, I’ve never seen anything like it.

That’s correct, it’s not 100% safe… right now I’m testing this method with my game to see what’s going to happen, if it worked then that’s cool but it’s not enough confirmation for me, so after testing I’ll create a new virtual machine with another version of Mac os and test the exact same file that worked on the other mac version.
if it worked then it’s a success…
If not then I wasted my time and it’s time to think with another clean mind on another way to fix this…

I’ll confirm if it worked…
Not leaving this until I confirm it’s safe to use this method…

@ddabrahim well sad news incoming…
It didn’t work with my game and immediately it gives me this message:

macc

Here is the report:

I don’t know if it’s because the virtual machine has only 128mb graphic display … it can’t go any higher.
Don’t know if it’s crashing because of that.

Right now I’m out of ideas…
I have no idea what to do.

Waiting for help from anyone…

Eh, that crash report is beyond me.
I can see that you don’t have a unique identifier, it is set to com.gdevelop.game. You should set that to something unique in the project settings, for example com.coriandergames.mikopuffball and make sure to never change that after publishing the game.

Virtual machines are famous for not being good for gaming and 128 MB VRAM certainly not a lot. macOS also famous for being problematic on none real Apple hardware.

At the moment I am also out of ideas, did try to search how other HTML5 game engines go about this and if experienced similar errors but I can’t find any info on publishing HTML5 to macOS on Steam. Everyone is talking about how to publish to Windows and the official docs make it look so easy and straight forward :face_with_raised_eyebrow:

If you can send me a temporary beta key in private I can give it a try on real hardware and confirm if the virtual machine is the problem or not.

@ddabrahim

Hmm, first of all I have some questions:
1- what is an identifier?
2- I changed it right now but it says that it’s for (android and IOS)
3- How can it help?
4- Why not change it after publishing? why is it important if it says that it’s for (android and IOS) and my game isn’t for those…

I changed it now and trying again,

I’m in for sure, I still don’t know yet how to send a beta key but I’m sure I can figure this out, anyway what version of Mac do you have?

  1. it is for the system to identify your application
  2. macOS also use it when grant permissions for example to run or to access a protected location.
  3. it is for security.
  4. because this is how the system identify the app not by name or location or signature, if you push an update out with a different identifier, it is going to be treated as a different app and instead of updating the previous, it may install alongside it and your app may lose permission to access location for example where the save game is located or to access files created by the previous version. Of course it is depends on your app/game how much a new id break the game, but this is the idea behind it.

I’m running macOS Big Sur 11.3, 8GB RAM, 4GB VRAM, Core i5.

1 Like

@ddabrahim I get now yeah, actually that might help … I hope but right now 128mb is definitely not enough for Puffball so I’m guessing this is the reason why it doesn’t work and crash when starting, but who knows, hopefully it’s that identifier thing.

I was just searching on google: what is Big Sur :sweat_smile:
Alright, that’s good news… I would like to get in touch in private to send you the key when I figure out how to get it, it that alright? And I might need your help with testing before release when the full version is ready.

Testing on a real Mac system is going to be very helpful…

@ddabrahim
I would like to test with you the two methods:-
1- Extracting the .zip file on windows then sending you the .app file
2- Extracting the .zip file on Mac (virtual machine) and sending you the .app file that’s inside the folder

And see which one works and stuff like that…

Sure no problem.
Here is some info about how to request/distribute keys:
https://partner.steamgames.com/doc/features/keys

1 Like

@ddabrahim Awesome, alright I just requested a key for beta testing and it should be here today or tomorrow, once it’s here, I’ll get in touch in private message and you should have access to the game, and you can test with me this and I can finally rest for some time knowing that the game will work on Mac once released, thank you so much for offering to help, this will help me a lot.

1 Like

Thanks. I Saw Many of your thread. I wanted to give you advice on how to sell your game. I didn’t know where to reach to you. Here or pm.

1 Like

@redcafe Hi, we can talk in pm