Icons and testing an exported web game

I looked through the forum and the tutorials, but I couldn’t find any answers for my problems, so here I go…

I would like to insert an icon into the window of my game, the small icon on the top left corner. I tried it with the event “Change game window’s icon”, I tried to insert a picture in png or ico format, or in different sizes. The icon changes, but not into the picture that I used , the icon looks like a small triangle. Maybe it’s a bug?

I was also wondering if I could test my exported web game (it started as a game for Windows) without uploading it somewhere?

I believe the Change game window icon is native only, in case of HTML5 you need to edit the index.html after export.
It pretty simple, just open the index.html in a text editor, find the tag, most likely at the very top and just insert the following code right below the tag:

<link rel="icon" href="icon.png">

Obviously replace “icon.png” with the name of your icon.

I’m not sure, last time I tried it did work for me in native games and I didn’t expect it to work in HTML5…

Preview should work fine even in Chrome, at least it does for me. But in case you want to play your game after export, Firefox should be able to run it locally by opening index.html.

Alternatively, you can also run a web development environment like WAMP or XAMPP, it allows you to run a virtual web server so you can run databases, websites and web apps locally on your PC for testing purposes.

You can also wrap your HTML5 game in to a native Windows, Linux and Mac application using NW.js if it what you asking:

Thank you for your fast reply. I am working on a native game, but the icon just doesn’t show on the native game window, so I wasn’t even thinking as far as for an icon for the web game… I’ll try testing the exported game with your suggestions :slight_smile: .

For me, the icon for the exported game for windows doesn’t show at all. In game setings, I have it uploaded to the desktop icon, but after the game is exported, it is still just the Gdevelop logo. Am I doing something wrong or is it because I have a free version? Can anyone explain this to me? Thank you all :).