Images from permium store packges not loading

Hi! I am trying to use assets from the “Fantasy Dreamland Bundle” I have bought from the store, but the assets seem to fail to load

The expected result is of course for the assets (currently just grass and water) to load correctly when trying to start a preview of the game, it shows fine on the editor

The actual result is a log like this one when checking the debugger:

Unable to load file{some id}/resources/{some other id}-Water Top_4.png with error:[object Event]

I would mention I tried to nagivate to the file using a browser, I get 403 (well, obviously becasue the asset is not free so there is authentication which needs to be done, maybe I miss some configuration on my project to make the preview load correctly?)

The preview:

I added again the asset and it works now, weird (even the water which I didn’t touch)
I am curious tho as to why it didn’t load initially

Edit: I have another werid problem, I started a network preview to show it on my phone, and the assets yet again don’t load.

They load completely fine when trying to open it from the browesr on my computer, what is going on?