Images saving incorrectly!

One day, all of the image files I created for my game started to save directly into my downloads folder! If I try to move the images to a folder, Gdevelop can’t use them! Please help!

You’ll have to re-import them or update the file locations of each image in the resources section.

I re added them in after I moved them to a folder, but they wont show up in preview…

The first thing I’d do to test it is start a new project and import the images again. See if Gdevelop saves them in the project folder (like it’s supposed to). If it does, then maybe your previous game file is corrupt and you need to use a new filename / folder.

This happened with multiple projects.

Ok you didn’t mention that before, you said “my game” singular not plural. Anyway next thing is to try reinstalling GDevelop… I’ve seen some problems get fixed this way. Remember to backup your project folders.

I’m sorry for not being specific. However, I have already tried uninstalling Gdevelop.

I don’t have many other ideas in that case.

I thought it might be a strange bug with the software, like it was stuck in some sort of destructive loop but then a reinstall should have fixed that.

Long shot but it might be that you have some kind of malware on your computer causing the problem. Personally I would try scanning for malware just in case. I had one last year which caused files to be renamed and become unrecognizable and unreadable by the host software. (I basically lost them permanently).

Eset the free online scanner helped to detect and remove that particular malware if you want to give it a try. The “one-time scan” takes a few hours >

I am unsure if it malware causeing the issue, as I have malwarebytes premium, which autoscans my computer every morning. But thanks for the help!

It’s probably not malware but when I had the malware last year I did try 3 or 4 different cleaners and Eset was the one which was able to detect it. The others I tried didn’t detect it. It’s up to you if you want to give it a try. (It’s possible that Malwarebytes isn’t detecting it).

Another thing to see first… if you right click on your GDevelop save folder, choose properties and make sure that “Read-only” is unchecked.

1 Like

Where could I find my save folder? Yeah, malwarebytes could not be detecting it,but I don’t really want to go and get another av. I also haven’t seen any real suspicious activity on my computer.

Create a new project and look at the path that Gdevelop saves it to automatically. It should say in the title bar right at the top of the screen. I’m a little surprised you didn’t know this because this is the location where your games should be saved.

Ok so the next thing to try… open a new object in the game, load a few images and then make sure that your game is saved in that folder which GDevelop automatically saves the game to. Now close GD, reopen and see if the images are loading.

Eset is only a temp download if you do a one time scan. It just downloads the files to a temp folder and then deletes them after the scan is finished

1 Like