Import in pixel format

Hello, when I import pixel art image the pixels are blurred gdevelop has a reimport function just like godot, how can I solve this?

Nothing about GDevelop itself will inherently blur imported art itself.

Do you have Linear scaling mode enabled in your game properties? Or are you using Piskel when importing and leaving the “Smooth Scaling” checkbox enabled?

Either of these will apply a basic version of anti-aliasing to the art, which will look blurry on pixel art.

1 Like

hello, im an idiot and i cant find anything in the resources tab that would allow me to untick smooth images, i can only see a drop down box with the options: rename, remove, open file, locate file, copy file path, scan for (images, audio, fonts, videos), remove unused (images, audio, fonts), remove resources with invalid path.

do you have any ideas?

Project Icon → Game Settings → Resources (sorry for the explicitness, I’m including it in case those new to GDevelop read this and wonder how to bring up the tab).

Click on the image in question, and near the bottom left is the “Smooth the image” check box (as per image)