In App Purchases Price shows 0

Hey,
so I’ve added In App Purchases in my app, but after uploading it to google play closed testing track and even after getting it reviewed by google, when i download the app and install the app on my phone the price somehow always shows 0.
In the google play console I’ve added those items using the same ID(name) as in Gdevelop, configured all the prices, activated the products but somehow it still shows 0.
When i click on those buttons, it will order the correct item, so i know they are linked properly, it’s just the price doesn’t update

I don’t think there is an issue in the events, since i basically copied what was in the IAP example, I’ve stored all the IAP Data in a structure just as the IAP example

I’ve tried just using “.price” instead of “.offers[0].pricingPhases[0].price”, but still the same.

Update1.
So after test buying one of the product, i somehow didn’t receive the product but my card got charged, and after if i click on the button again, it tells me “error you already own this item” even though it is set as a “consumable” item. It tells me the same even after reopening the app or reinstalling.

Can someone tell me what I’m doing wrong or if someone has the same issue?
Is it possible that there is some issue in the IAP extension itself?

I have the same problem, I don’t know how to get the price, I would also like to verify when the user pays to remove the ads, because when I close the game and come back I don’t know how to verify.

I used the template: “https://thegemdev.itch.io/gdevelop-in-app-purchase-template” but it doesn’t work.

i have the same problem, even do the same like a tutorial