Is There Any Special Command/Way To Activate The Dialog Tree(Solved)

Here is what I’m using Now:

and this is the event sheet:

But when i run the preview, nothing happens except the scene background being displayed. What am i doing wrong? This is the first time i am working yarn so soft gloves please, :slight_smile:

There are examples. I’ve had trouble really understanding it but I also haven’t used it much.


Thanks a lot, friend, :slight_smile:

1 Like

You need a text box for the dialogue to go into. It won’t appear otherwise. And there are a few other steps too. The video should help… though I am a little biased :wink:

1 Like

the tutorial was excellent, great work, i was wondering if there was a way to embed animated gif/video/png sequence directly into a yarn node, do you know anything about that, or do i need to switch back and forth between the dialogue tree extension and an event based video, if yes, can you give me any pointers regarding the same?

Yup, we can indeed embed a video in a yarn node, just change the markup to HTML in settings and paste the iframe embed code. It can be done, i dont know if it effectively works or not yet!

I’m glad the tutorial helped. I have no idea about embedding videos within dialogue, nor have I ever seen anyone else try that, sorry. I haven’t attempted to use video in GDevelop so far, but I would likely use a Yarn variable as a trigger for GDevelop to play it, rather than embed links to videos in a node in the Yarn editor. But, that’s just me thinking out loud. Enjoy your experiments.

The video embed is working in the preview inside yarn, is there any chance of it appearing it in gdevelop runtime which it doesnt seem to do! I’ll try out your suggestion!

Another trigger could be the ‘Branch title has been visited’ condition. So, if one of your dialogue nodes is called ‘hello’ (or whatever), you could check if that has been visited and do something if it has.


thanks a lot, buddy!

1 Like

@worriedpixels I really hope you dont get mad at me for tagging you. I followed your tutorial and everything was working till I made some changes to the node links. Now, it shows the branching options but nothing happens when i press the designated key. Pressing the conversation forward key takes me back to the beginning of the first node of the dialog. Here is my event sheet:

I can’t offer 24 hour Yarn support :wink: but I was at my computer doing GDevelop things, so I’ll try to help.

(Edit: the next paragraph won’t be a problem because you use a different button to start and end dialogue, but it’s something to keep in mind.

If your DialogState variable never gets changed to 1, then you might end up in a loop, where you exit dialogue and it immediately starts again because DialogState is still 0. I don’t see the variable being used anywhere else in your events, so consider dropping the ‘global variable DialogState = 0’ condition completely, unless you plan to use it later on when you have more dialogue.)

As for your options not working, I can’t see anything obvious in your events, especially if they are based on my tutorial and they were working until you made changes to the nodes, specifically. If the list of node (branch) names appears in the list when you run your game and you can move up and down and select one, but then it goes wrong after that: check the node names and the names of those nodes in your options code are the same. It is case-sensitive, so if your list item has ‘yes’ in it, but your node is called ‘Yes’, it won’t work.

[[Absolutely. It’s not going very well, after all. |yes]]
[[That’s a terrible idea. I quite like being alive. |no]]
[[I need time to think about it. |unsure]]

I would also use a ‘trigger once’ for your ‘Branch title has been visited’ events. Otherwise these will happen over and over again because the conditions will stay true until you close your preview and run it again.

Thank you’s are always nice :slight_smile: Even if you’re still stuck, closed this thread, and made a new one. Best of luck with your game.

PS. I don’t think you can have spaces in node names. I just spotted that in your new thread. I tried adding spaces to some of my node names, as an experiment, and it broke my dialogue. Try underscores instead and see if that helps.

I didnt want to disturb you too much, and I am being totally honest. You know, your help is just goodwill towards the game development community and i am shy of testing it too much!