Keyboard keys not working

After I compile manually with electron, my arrow keys (Windows 10) no longer work.
Yet they work fine when I test the game in Gdevelop. Appreciate any help - Thanks.

Quotes aren’t needed, unless you’re using the expression condition.

Thanks for your reply Gruk.
Yes, I tried it without the quotes and it made no difference.
This is very strange - I’m sure it used to work.
As I said, it works fine when running within Gdevelop.
I need to resolve this so I can publish my game for free on Itch-io.

All good now! I tried it again this morning and it’s suddenly working (Electron desktop manual compile).

When Gdevelop asks you to choose an export folder for the build, this time I made sure I had FIRST saved my project in that same folder. It seems Electron needs that, otherwise the build looks OK and all my ghosts are moving as they should, but the Pacman doesn’t move with the keyboard controls.

I guess everyone except me knows you should save the whole project first into the same folder you ask Gdevelop to place the export.

Thanks everyone for looking at this, especially Gruk.

While I can’t speak to your issue specifically, I do not export to the same folder as my project (and wouldn’t recommend it, since it can override project files corrupting your actual project depending on the files involved).

However, I’ve just tested with the default platformer, manually overriding all of the controls with up/down/left/right, and it works fine even with a manual build. I also tested using Not-a-Vania with updating the global variables for controls to Left/Right/Up/Down and it also works after a manual build.

Sadly, I’m not really sure what may be causing the issue for you. :frowning:

Thanks for the clarification Silver-Streak.

So it seems the issue was not caused by what I thought it was.

Are you manually building with Yarn or another command line tool? If so, is Yarn (and electron builder) the most recent version?

I’m manually building with Yarn by issuing “yarn && yarn build” from within Windows CMD.
Initially it asked me to update and I did as it instructed.
I’ve repeatedly re-built and tested and every time it works fine today.
I have no idea why yesterday the game ran as an .exe, but the keyboard was not working.
Anyway, I can now publish them for free download.
I have two Pacman games in the traditional sense, but with my own spin on them.
They are nothing great, but they were a huge learning experience which I enjoyed.