I have two layers, one is the base layer with 3 objects that interact when mouse pointer is hovering them.
A second layer on top of the base layer which holds something like a pop-up with a few settings/options
The issue is that even if the Z-Index is set up accordingly and the second layer (on top of the base layer) is on screen, the elements from base layer are still intercatible.
How to disable all functionality/interaction of the base layer when second layer (settings panel) is on screen ?

Add an Invert condition Visibility of a Layer “secondlayer” to the buttons on base layer.

Thanks a lot. Might be a good suggestion but I’ve used a “work around” tweaking X and Y Position of the object.

I’ve had the same problem. In my case I discovered I had made an event that should have been a sub event, a main event. The event ended up showing a layer continually (z layer hid it from view), instead of only after a condition was met !
Hope this helps someone.