Loading issue (upside down flickering loading numbers!)

Hi, I have a big issue while loading the game on my Android device (no issue while playing on Windows 10 preview).
The loading screen (the GDevelop one without the logo) start to show strange upsidedown big loading numbers randomly. Sometimes the game start, sometimes the game stop loading at different percentage.
If the game load, it start flickering and it slow down. As you can see, a big sprite with an upsidedown “Reader ID” appear briefly on screen…

Another thing:
If I use the same GDevelop project to build both Free Edition (com.tra.theresearchage) and Deluxe Edition (com.tra.theresearchagedlx) of my game can I encounter issues like this?



That’s the weirdest thing I’ve ever saw, I wonder what could have gone so wrong that this could happen. Maybe try reinstalling GDevelop?

Yes, it’s so weird! I added some screenshots showing the loading odd % number and the odd sprite in game, maybe it’s a loading sprite issue or a bugged external events?

Do you have more details about the phone model and the android version?
Are there big files?
If you have a link to the web version (not a .apk) i’ll take a look if something seem strange to me.

I have a Samsung Galaxy Tab S2 (SM-T815) with Android 7.0

Unfortunately, I don’t have a link of the web version because this morning I updated the game to try to solve this big issue (It seems solved now). But if it came back, I will immediately create a link to the web version to let you investigate.
Based on this suggestions TOPIC 1 TOPIC 2 I removed the latest external event I made and I deleted every broken link in GDevelop using the automatic option at Game Settings → Resources → Delete all broken link

Thank you!
The Research Age DEV

Nice VFX :grin: #manipulation #subliminal

Sadly, the issue is still there and now things goes worser:

  • I can’t export the game to the web!
  • One time an error appear after closing GDevelop
  • The app continue to show strange things (bugged loading screen, weird flickering black frames, upsidedown giant sprites for one frame, stranges black and white squares for one frame randomly.

I hope someone can help me! bug3

You say “the issue is still there” but last time you said it seemed solved.

Error 504 is a network error, such things happen. Can be on your side, on GDevelop’s side, or anywhere in between.
If the error persists tomorrow, maybe it’s something else.

JavaScript error usually pops up if you close GDevelop without closing the previews.

Regarding all the glitches, do you get the same issues on other computers/devices? Could be a dying graphics card, faulty/obsolete drivers, or incompatible hardware.

We can’t help much if you don’t share the game or the project, but you can press ctrl-shift-i inside GDevelop and inside preview, to look for errors in the Console tab.

  • It seemed solved but then the issue came again.
  • The error 504 persist from weeks and even after I reinstall GDevelop.
  • My connection works fine
  • Yes, the issues appear also on other Android devices, but not in Windows preview
  • I am willing to share the project with you, Gruk, can I send you a link to the project in private?

For anyone who want to investigate the link to the game is this
all the issues doesn’t appear the first time you try the app, but sometime later.

Send it to Bouh or arthuro, I don’t have all their technical skills :slight_smile:

Done. I send a private message to Arthuro! I hope it can found the issues main cause.

Let’s hope, it’s a pity to stop this project now that my game is in the GDevelop showcase! :heart:

For the glitches it definitely looks like some incompatible GPU, faulty driver, or even a faulty GPU under stress. Not sure we can do anything in GDevelop itself, as this probably runs fine on other Android devices :confused:

For the 504, can you try again today and if it does not work, can you send a private message with the exact time you started the web build? I’ll take a look to see if there is something wrong with your game or account :slight_smile:

I took a look at the project, and after a very quick check up, it seems there are no kind of errors that could cause this, though there are a few external events linking errors and faulty expressions:

The next thing to check if if there are no images bigger than 2048x2048 as some mobile devices dislike those

First of all, thank you.

I’ve sent a private message to 4ian to let him investigate about the error when I try to export online the game.

  • I found some images that was too big, I have deleted them
  • I found that sentence arthuro555 talk about but the text was correctly between two “text”, weird!
  • How can I spot the exact external event that has linking errors?
  • arthuro555, could you export my project to the web correctly?

Some gamers in my poll tell me that they had the same issues I had in my tablet. I repeat, the bugs doesn’t appear when you play the game for the first times, but later. Now I’m trying to discover if my new Tab S6 have the same issues.

Did someone play the game entirely and encounter the bugs we are talking about?

You should avoid using quotes inside your text, I remember having some strange bugs with that.
If you really must have quotes, I guess there’s a proper escape character. :thinking:

Please, GDevelop members, if you have time play my game and after that do this poll

For Gruk:
I don’t use quotes at all, I was talking about the quotes that must open and close a sentence, sorry for my bad english :slight_smile:

Gruk, did you play my game in its latest version? (1.2.6)
Did you encounter the issues?

I was talking about this:
Looks like there’s extra quotes at the beginning.
No, I didn’t try your game.