Never ending screen problem

I have a project with the resolution of 1280 x 720 and my objects are in 80 pixels to make it even to the resolution.

It fits well in the editor but when you playtest it in full screen…

There’s a little part in the right that ruins the project. I know it’s because it needs to fit the screen of the device and I guess the higher the width of the device, the longer the gap will be. I don’t want to set the screen size as exactly 1280 x 720 because I think there will be a black border on some devices. I want to make this game fit all devices without that gap in the right. Any idea how to fix this.

If the screen does not fit the resolution, there will be a boarder. Via setting you can decide if it’s on top/bottom or left/right.
But you can at least even out the boarders to both edges by putting an object in the middle and center the camera on it.

1 Like

I get your point but is there a way to fix this without border?

Intenta anclar tus bordes para que siempre estén pegados al borde de cualquier resolución

1 Like

this is a solution. this will always update the res to the screen. so even if you resize it in window mode, it will always fit boarderless. but the problem is, that you never know, what the player is able to see, since the camera content is not resized.
also using the condition fullscreen is activated seems not to work for me, so it runs conditionless, wich is expensive, and can even crash pixi renderer with too much resizing of the window.
i have tested it with a timer (thats how i did it in my game), but it doesnt seem to work in this case.

i think living with boarders is the better solution.

1 Like

Thanks! I guess I will stick to the borders.

Try this:

1: Set to “No changes to game size” in Game Settings > Properties.
2: In your event: (condition) “At the beginning of each scene”, put (action) “De/activate Fullscreen” (“Activate Fullscreen” - set to YES, and “Keep aspect ratio” - set to NO).
3: Test… It worked for me…

1 Like