Object collisions don't work when the "platform" behavior is enabled

Hello! When I set the “platform” behavior to the sprite, the collision actions with it stop working. When I disable the “platform” behavior, collisions work fine.

With the behavior you have the added conditions of IsClimbing, IsOnfloor … but there’s also a harder to find 'Is object on a given platform" condition. It’s not under the objects. It’s under [other conditions]. It will make the first colliding platform the picked object.

As I understand it, collision isn’t disabled. It’s just that the platform behaviors prevent the objects from colliding by keeping the objects slightly apart from each other.

1 Like

Thank you very much. I understood in which direction I should look.

1 Like