Platformer Help

I’m creating a game in which you solve puzzles and platform across some treacherous terrain on a quest to save soda from the clutches of an elegance-obsessed princess. During one of the tutorial levels, you earn a powerup that you can use to slingshot paper balls at enemies and even use as a platforming mechanic. Along the way, you can pick up sheets of paper that can be crumpled into paper balls and thrown using the slingshot mechanic, but these paper balls can’t be thrown until you actually find the powerup first. While this mechanic worked just fine at first, after a while it just…stopped. Worse, nothing I do seems to resolve the issue. It doesn’t just happen for the browser version; in the mobile version of the game, the button just doesn’t work at all, nor do any of the other buttons (which is especially bad because it’s a mobile-intended release). I’ve tried everything I could think of to fix the problem, but nothing seems to work.

It’s like every time I add a new mechanic, another stops working the way it should. If there’s anyone that can look into it and give me some tips on what to fix, that would literally be a game changer.

Thanks for your help in advance,
Hype’s Game Room

Another note: Why I mentioned “desktop version” is because I intend to release a 3-4 stage demo on the website of the series the game is based on. Occasional updates are released on, where the game is hosted.

Hi, can you post some screenshots of your events?

Also, are you using the scene’s event sheet or an external one, or a combination of both?

I’m using the scene’s event sheet for each scene, importing management groups in each one. (I tend to copy and paste scenes to keep the settings the same so I don’t have to re-import everything.)

This is for the slingshot mechanic. I keep that in the ObjectManagement group.

EDIT: I apologize for the delay in my response.

And this is for the virtual controls.

Okay, so now the mechanic works, but it just fires every paper ball at once in rapid fire mode when it’s supposed to go one at a time. How do I fix it?

Try adding a “Trigger once” condition to your z key press where you have the ball being created at the player position. This should make it so they fire one at a time.

Also, I’m not sure if this makes any difference or not (probably not if it’s working as you intend) - maybe someone can confirm either way - but I see a question mark in one of your global variables.

That was just for style.

Oh okay, because sometimes variable names can be a little touchy.

Great news! The problem is solved.

The only thing standing in my way now are the mobile buttons. Ironically, they work on anything but mobile.

It’s good practice to explain how you solved the problem, for future readers. :wink:


I literally just did what @Phenomena said and added a “Trigger Once” condition. That fixed everything.

1 Like