Platforms suddenly no longer working as platforms...?

The last time before the issues started that I had previewed my project, there were no issues (aside from some goofy hitboxes that I fixed.) with anything that I had implemented. Player controls were working properly, animations were properly initiated, platforms were solid, etc.

The next time I try to preview the game after adding a simple event to allow the player to crouch if he is not moving and is on the floor, none of my platforms work as platforms. The player character simply falls through them and off of the screen. Nothing about my platforms or sprites has changed in between the initial preview and now. I have tried removing the platform automism and re-initiating it, to no avail. If anyone can help, I would greatly appreciate it.

4ian did some improvements in the Platform automatism, but the platform example works fine in the native and HTML5 platforms, can you share your project (.gdg file + resources)? You can send it in a PM if it’s private :wink:

The project would be really useful indeed to see what went wrong :slight_smile:

I have no problem posting the project here (None of the assets are my own anyway). Give me just a little bit.

Here is the game and what little assets I am currently using. (1.42 MB)

You can’t have physics automatism and platform automatism on your character, only one or the other.

I had no idea I had even enabled that…

Welp, thank you very much for your help.

Removed the Physics automatism, to no avail. Still having the same problems. Just wondering, could the Z order have anything to do with it?

Fixed. I just had a wierd PC goof it seemed. Removing the automatism worked out after all.