Preview broken in ios app

EDIT: this issue is being tracked in GitHub as 5838
So far the root cause appears to be a 403 authentication error from the server when trying to load the resource PNG file from the cloud bucket URL

Preview seems broken in the iOS app after I saved the project locally on the PC, and then saved it back to cloud and opened it in the iOS app. I had been experimenting with a JavaScript event on PC when the issue happened, which seems like it may be related because I can see the background color change from the JavaScript code (update: since found out that the color change is due to the joystick sprite being blown up and nothing to do with the JavaScript event). The game seems stuck right after loading and the camera looks to be zoomed in very close. If I load the game in the web app on iOS or in the PC app it seems fine. Deleting the extension with the JS event did not help.

1 Like

I restored my project from GitHub to before I made the JS event addition and the same issue occurs. I wonder if it’s just related to saving locally on the PC and then saving back to cloud. I can upload a zip of the local PC project if it will help

EDIT: went back to a previous commit from August and the same issue. Maybe something broke in an iOS app update?

I disabled all of my events and deleted all behaviors and the preview is still messed up. Started a new project from scratch and it seemed ok.

EDIT2: something strange is happening with custom sizes. When I resize an object using the editor or events, in the preview it becomes huge taking up the whole screen, but in the scene editor it looks correct.

1 Like

I have a zip of the project file that has the issue but I’m not sure where I can host it. The local project works fine on my PC, saved it to cloud and it works fine on PC, works fine in web editor on iOS, but doesn’t work on iOS app.

Web editor preview

iOS app:

In the iOS app it seems like any object with a custom size becomes huge. The screen looks grey because the joystick is covering it, if I disable the custom size in the editor then the background is no longer grey but becomes green because the trees are custom size

Hoping someone can take a look at this, I paid for a subscription on the app but now it’s useless to me for this project.

iOS about

1 Like

Seems like root cause may be that the engine thinks that the width and and height of some objects is 1px by 1px which causes them to draw in the wrong location and scale incorrectly when using a custom size. More info on my other post: Get objects to draw from origin

I am still looking for an explanation as the issue seem to be specific to one project, I do not see an issue with the same object/asset when creating a project from scratch

1 Like

Seems the issue was caused by object image, changing the resource URL from a project resource back to the asset store URL somehow fixed it, but still not sure why.

See my other post

Did one final check to download the images from both the project resource and asset store URLs and compared using winmerge, and the files are identical.

Not sure what else I can do at this point, and have not gotten a response from a developer here or on discord. Created a ticket on github, hopefully somebody looks at it.

Started poking around in JS events. The baseTexture.resource of the PIXI sprite is not valid when I preview from the iOS app, which I’m guessing is related to the width/height being 1 px. Still no idea what causes the resource to be invalid though.

EDIT: noticed baseTexture.resource.src is undefined when the issue occurs, so perhaps a bad URL was passed?

I’m having a similar problem which started 2 or 3 weeks ago. Game is working fine on Mac but now downloads weird on iOS preview and can’t be played (worked okay previously).

If you are using assets from the asset store, you can try changing the resource URL back to the asset store URL to see if it fixes your issues (I have only seen the issue for resources located at

Thanks. How would I check if the object URL is project or asset?

Go into the Project Manager → Resources

select a resource and then look at the file field

and see if the URL is

If so you can do Edit → Choose from asset store to change the URL back to the asset store.

Brilliant thanks :pray: I’ll let you know how I get on.