Properly Add Tilemap Object to my game scene(resolved)


This time i am working on a third person shooter mini game and am trying to use a Tiled map for that. I have provided the atlas in the necessary fields along with the json file. but when i try to place the map on the scene, it is showing a red cancel symbol. can anyone help?

I have had this happen before. When making the new tileset, there is a tick box to embed it into the map. If you did not tick that box it will not work, and as I have tried, you will have to start over again because I have not found a way to edit those options.
Screenshot 2023-05-25 at 16.04.38

There’s a few things that could be going on.

  • Embedding it in the map is not required, but does make things simpler.
  • Make sure your atlas image isn’t over 2000x2000 pixels. They have the same size restriction that any image asset does.
  • Ensure your tilemap itself isn’t set to “Infinite size”. That isn’t normally supported by any engine, GDevelop included.
  • Ensure you are choosing File > Export and exporting as .json, not choosing file > save. In many cases Tiled will default to saving as a .tmj extension, just rename that (in the export window) as .json.

If all else fails, I’ve personally found LDTK to be much simpler to use than Tiled, as far as tilemap support is concern.

By exporting the map as json, i could drag my map into the editor. I think the File> Export tip worked. But the problem i now face is that only a very small part of the map is actually visible though I have bumped up by scene size. The map preview presently is:

While the original map is something like this:

I got the map working in GDevelop but had to recreate the map as @MisguidedCouch said i would need to.