PS5 Controller support

Hey so I got my ps5 controller working with all my games except the one I’m making through Gdevelop. I have it set up through steam, where it launches through steam, but for some reason it wont work. I use my generic PC controller and it still works just fine. Does anyone know how to get this working?

I’m not sure where the right place to ask this question is, if it’s here or the steam forums. Sorry if this is the wrong place

1 Like

Are you using the Gamepad extension? If so, the Dualsense is detected as a normal USB Gamepad and works fine for me.

If you’re using Steam it might be due to having Steam’s playstation controller support enabled, which changes the emulation/how it works, and that might conflict. Try turning that off.

Yes, I do have the gamepad extension installed in the game. It works fine with my regular pc controller.

I tried launching it both through steam and just through the preview button, but neither seem to work for me. I tried disabling the playstation controller support in stream, didnt seem to work either.

In the “game controllers” setting in windows it shows up at just “wireless controller”, but all the buttons work in test and everything. Just for some reason not my game.

You might check that you have the newest version of the extension installed.

My dualsense even works directly in the browser with the Gamepad Multiplayer Platformer example: GDevelop 5

You might try there. If it works when you preview on that example online, then something’s odd on your local install of the extension.

Oh hey, that told me a lot. For some reason it’s set up as controller 2.

Not sure how to change it to controller One, but Ill try to find that out!


Ok, so new problem. I got the controller to spot 1. Now whenever I go to play the game, my player is immobile until I turn off the Dualsense controller (like I can’t even move my guy with my keyboard). Any ideas?

Still sounds like you’re on the old version of the extension. That sounds like a bug back from 0.07, I think.

ah, you’re right. Sorry about that, I was apparently still on 0.06. Thank you for all the help!

1 Like