Regarding the 'Type-on text effect'

I’m interested in this code that was created (GDevelop 5) that makes the letters of a text appear one by one

It worked great when I replaced the default text, but I noticed that when a text string was fully typed it disappeared. I am not sure what part of the events is making this as I am not very knowledgeable on what is going on in the code :sweat_smile: What is causing the problem and how could it be fixed?

So I tried fiddling around with the code, and I think this part is causing the problem:

The -1 at the end of the ‘text of the scene variable’ action seems to be affecting the text, maybe clearing it? When I replaced it with larger numbers (+1, +10, etc) it previewed that amount of letters instead (For example, if you input +3, it shows ‘This is a string’ then ‘Thi’)
Again I’m not knowledgeable with how the code was set out but I’m trying to learn as much as I can :slight_smile:

1 Like

it seems that it shows a substring, maybe it was thought to be in a loop and show letters 1 by 1.
So if nothing is shown with -1 means that this value is <0, probably you problem is with variable
Maybe full code will help

1 Like